RFR: 8234502: Merge GenCollectedHeap and SerialHeap [v12]

Chris Plummer cjplummer at openjdk.org
Thu Jan 11 18:35:35 UTC 2024


On Thu, 11 Jan 2024 15:46:45 GMT, Lei Zaakjyu <duke at openjdk.org> wrote:

>> 8234502: Merge GenCollectedHeap and SerialHeap
>
> Lei Zaakjyu has updated the pull request incrementally with one additional commit since the last revision:
> 
>   restore and rename 'GenCollectedHeap' to 'SerialHeap'

Changes requested by cjplummer (Reviewer).

src/hotspot/share/gc/shared/vmStructs_gc.hpp line 31:

> 29: #include "gc/shared/cardTable.hpp"
> 30: #include "gc/shared/collectedHeap.hpp"
> 31: #include "gc/shared/genCollectedHeap.hpp"

vmstructs purpose is to support SA. Thus renaming should be done here instead of deletion. You need to restore this line and rename genCollectedHeap.hpp -> serialHeap.hpp.

src/hotspot/share/gc/shared/vmStructs_gc.hpp line 114:

> 112:   nonstatic_field(GenCollectedHeap,            _young_gen,                                    Generation*)                           \
> 113:   nonstatic_field(GenCollectedHeap,            _old_gen,                                      Generation*)                           \
> 114:                                                                                                                                      \

You need to restore these lines and rename GenCollectedHeap -> SerialHeap.

src/hotspot/share/gc/shared/vmStructs_gc.hpp line 149:

> 147:                                                                           \
> 148:   declare_toplevel_type(CollectedHeap)                                    \
> 149:            declare_type(GenCollectedHeap,             CollectedHeap)      \

You need to restore this line and rename GenCollectedHeap -> SerialHeap.

src/hotspot/share/gc/shared/vmStructs_gc.hpp line 180:

> 178:   declare_toplevel_type(DefNewGeneration*)                                \
> 179:   declare_toplevel_type(GenCollectedHeap*)                                \
> 180:   declare_toplevel_type(Generation*)                                      \

You need to restore these lines and rename GenCollectedHeap -> SerialHeap. I'm not sure why DefNewGeneration and Generation were deleted. I assume they are still present.

-------------

PR Review: https://git.openjdk.org/jdk/pull/16927#pullrequestreview-1816257350
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449251031
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449248757
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449249061
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449249834


More information about the hotspot-gc-dev mailing list