RFR: 8234502: Merge GenCollectedHeap and SerialHeap [v12]
Chris Plummer
cjplummer at openjdk.org
Thu Jan 11 19:58:42 UTC 2024
On Thu, 11 Jan 2024 18:31:49 GMT, Chris Plummer <cjplummer at openjdk.org> wrote:
>> Lei Zaakjyu has updated the pull request incrementally with one additional commit since the last revision:
>>
>> restore and rename 'GenCollectedHeap' to 'SerialHeap'
>
> src/hotspot/share/gc/shared/vmStructs_gc.hpp line 31:
>
>> 29: #include "gc/shared/cardTable.hpp"
>> 30: #include "gc/shared/collectedHeap.hpp"
>> 31: #include "gc/shared/genCollectedHeap.hpp"
>
> vmstructs purpose is to support SA. Thus renaming should be done here instead of deletion. You need to restore this line and rename genCollectedHeap.hpp -> serialHeap.hpp.
It looks like the include of serialHeap.hpp is already taken care of by vmStructs_serial.hpp, so deleting this line looks like it is ok.
> src/hotspot/share/gc/shared/vmStructs_gc.hpp line 114:
>
>> 112: nonstatic_field(GenCollectedHeap, _young_gen, Generation*) \
>> 113: nonstatic_field(GenCollectedHeap, _old_gen, Generation*) \
>> 114: \
>
> You need to restore these lines and rename GenCollectedHeap -> SerialHeap.
Nevermind. I see now that this moved to vmStructs_serial.hpp
> src/hotspot/share/gc/shared/vmStructs_gc.hpp line 149:
>
>> 147: \
>> 148: declare_toplevel_type(CollectedHeap) \
>> 149: declare_type(GenCollectedHeap, CollectedHeap) \
>
> You need to restore this line and rename GenCollectedHeap -> SerialHeap.
Nevermind. I see now that this moved to vmStructs_serial.hpp
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449324632
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449318718
PR Review Comment: https://git.openjdk.org/jdk/pull/16927#discussion_r1449319113
More information about the hotspot-gc-dev
mailing list