RFR: 8328508: Unify the signatures of the methods 'address_for_index' and 'index_for' [v2]
Guoxiong Li
gli at openjdk.org
Thu Mar 21 00:40:34 UTC 2024
On Wed, 20 Mar 2024 18:09:55 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:
>> Guoxiong Li has updated the pull request incrementally with two additional commits since the last revision:
>>
>> - Revert ObjectStartArray::block_start_reaching_into_card
>> - Drop unnecessary type conversion.
>
> src/hotspot/share/gc/parallel/objectStartArray.inline.hpp line 48:
>
>> 46: HeapWord* ObjectStartArray::block_start_reaching_into_card(HeapWord* const addr) const {
>> 47: const uint8_t* entry = entry_for_addr(addr);
>> 48: uint8_t offset = *entry;
>
> I kind of like the original style, as it has a single de-reference. (It's indeed rather subjective.) Also, this change is completely unrelated to this ticket.
Reverted.
> src/hotspot/share/gc/serial/serialBlockOffsetTable.hpp line 53:
>
>> 51: uint8_t* _offset_base;
>> 52:
>> 53: void fill_range(const uint8_t* const start, size_t num_cards, uint8_t offset) {
>
> I think the first arg should be `uint8_t* const start`. Then, the `void*` cast below can be dropped.
Fixed.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18405#discussion_r1533095689
PR Review Comment: https://git.openjdk.org/jdk/pull/18405#discussion_r1533095665
More information about the hotspot-gc-dev
mailing list