RFR: 8346920: Serial: Support allocation in old generation before GC [v2]
Guoxiong Li
gli at openjdk.org
Tue Jan 7 06:56:34 UTC 2025
On Mon, 6 Jan 2025 14:37:47 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:
>> src/hotspot/share/gc/serial/serialHeap.cpp line 334:
>>
>>> 332:
>>> 333: bool first_only = !should_try_older_generation_allocation(size)
>>> 334: && is_long_enough_from_prev_gc_pause_end();
>>
>> Is the `first_only` actually `young_only`? It means that the allocation is only attempted in young generation?
>
> That's true. I believe Serial used to support >2 generations, so some generic names are left as is. Fixing it requires updating in multiple places, such as the method name `older_generation`, arg in `attempt_allocation`, etc. How about we do that invasive but pure refactoring in its own PR?
Yes, such refactoring should be finished in other issues.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/22899#discussion_r1904984586
More information about the hotspot-gc-dev
mailing list