RFR (XS/T) 8245703: 32-bit build failures after JDK-8243392

Aleksey Shipilev shade at redhat.com
Mon May 25 07:59:56 UTC 2020


On 5/25/20 9:56 AM, David Holmes wrote:
>> diff -r 438102b06fc0 src/hotspot/share/memory/metaspaceShared.cpp
>> --- a/src/hotspot/share/memory/metaspaceShared.cpp      Mon May 25 11:29:56 2020 +0800
>> +++ b/src/hotspot/share/memory/metaspaceShared.cpp      Mon May 25 08:51:16 2020 +0200
>> @@ -259,5 +259,7 @@
>>     assert(DumpSharedSpaces, "should be called for dump time only");
>>
>> +#ifdef _LP64
>>     check_SharedBaseAddress();
>> +#endif
> 
> I'd prefer
> 
> LP64_ONLY(check_SharedBaseAddress();)
> 
> but either way looks good and trivial.

Yeah. Up to Thomas to decide which style to use here, I guess. I tried to match the format of
subsequent block:

 void MetaspaceShared::initialize_dumptime_shared_and_meta_spaces() {
   assert(DumpSharedSpaces, "should be called for dump time only");

+#ifdef _LP64
   check_SharedBaseAddress();
+#endif

   const size_t reserve_alignment = MetaspaceShared::reserved_space_alignment();
   char* shared_base = (char*)align_up((char*)SharedBaseAddress, reserve_alignment);

 #ifdef _LP64
   assert(CompressedKlassPointers::is_valid_base((address)shared_base), "Sanity");
   // On 64-bit VM we reserve a 4G range and, if UseCompressedClassPointers=1,
   //  will use that to house both the archives and the ccs. See below for
   //  details.
   const uint64_t UnscaledClassSpaceMax = (uint64_t(max_juint) + 1);


-- 
Thanks,
-Aleksey



More information about the hotspot-runtime-dev mailing list