RFR: 8266404: Fatal error report generated with -XX:+CrashOnOutOfMemoryError should not contain suggestion to submit a bug report [v2]
Kevin Walls
kevinw at openjdk.java.net
Fri May 14 10:18:42 UTC 2021
On Thu, 13 May 2021 08:06:24 GMT, David Holmes <dholmes at openjdk.org> wrote:
>> A simple fix to add a new VMErrorType (OOM_JAVA_HEAP_FATAL) to indicate we've requested a Java OOM error to be fatal. A new overload of report_fatal is provided to allow this to be passed through.
>>
>> VMError has an existing notion of "should_report_bug" but that encompasses more than just printing the bug submission URL, so I added a new specific check for that.
>>
>> Checked hs_err files before and after with the fix, from the CrashOnOutOfMemoryError test.
>>
>> Tested tiers 1-3 for good measure.
>>
>> Thanks,
>> David
>
> David Holmes has updated the pull request incrementally with one additional commit since the last revision:
>
> Review comments from Thomas
Marked as reviewed by kevinw (Committer).
Hi David, looks good.
I get it now I've found that should_report_bug() really means "is vm internal error". Literally, "is this NOT a native memory allocation failure".
If you had time to rename should_report_bug() "is_internal_error" or similar, I think that would make vmError.cpp significantly more readable. (It's not a problem in the function you're adding, it's the old should_report_bug that seems misnamed, and more so now it has a similar related function.)
-------------
PR: https://git.openjdk.java.net/jdk/pull/4006
More information about the hotspot-runtime-dev
mailing list