RFR: 8267191: Avoid repeated SystemDictionaryShared::should_be_excluded calls [v2]

Ioi Lam iklam at openjdk.java.net
Tue May 18 18:56:46 UTC 2021


> `SystemDictionaryShared::should_be_excluded` is called during CDS dump time to see if a class should be excluded from the archive. This function calls itself to check super types. As a result, some classes many be checked more than once.
> 
> The repeated calls slows down dumping. Also, If a class is excluded, we will see multiple warning messages like this, which is too verbose and confusing.
> 
> 
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> Skipping org/eclipse/osgi/util/NLS: Signed JAR
> 
> 
> BTW, to make the code a little easier to read, I also changed
> 
> 
>  warn_excluded(k, "Failed verification");
>  return true;
> 
> 
> to
> 
> 
> return  warn_excluded(k, "Failed verification");

Ioi Lam has updated the pull request incrementally with one additional commit since the last revision:

  @dholmes-ora comments

-------------

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/4070/files
  - new: https://git.openjdk.java.net/jdk/pull/4070/files/f1e1e276..b31408a4

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=4070&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=4070&range=00-01

  Stats: 3 lines in 1 file changed: 0 ins; 0 del; 3 mod
  Patch: https://git.openjdk.java.net/jdk/pull/4070.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/4070/head:pull/4070

PR: https://git.openjdk.java.net/jdk/pull/4070


More information about the hotspot-runtime-dev mailing list