RFR: 8271569: Rename cdsoffsets.cpp to cdsConstants.cpp

Ioi Lam iklam at openjdk.java.net
Thu Sep 9 21:55:07 UTC 2021


On Thu, 9 Sep 2021 18:13:10 GMT, Yumin Qi <minqi at openjdk.org> wrote:

> Changed cdsOffsets.cpp to cdsConstants.cpp, now the offsets and constants are initialized static and searched separately.
> The offsets array could not use 'constexpr' since g++ on MacOs and VSC++ on Windows complained reinterpret_cast in 'offset_of' should not be used in constexpr initialization. Changed some field access for forming global list first.
> 
> Note with 'git mv' to rename cdsoffset.cpp to cdsConstants.cpp, same for cdsoffsets.hpp to cdsConstants.hpp, due to the contents changed more than 50% so git will not think cdsConstants.cpp is renamed from cdsoffsets.cpp. Instead, it is regarded as a new file.
> 
> Tests: ter1-4
> 
> Thanks
> Yumin

Looks good. Just some small nits.

src/hotspot/share/cds/cdsConstants.hpp line 29:

> 27: int    get_cds_constant(const char* name);
> 28: size_t get_cds_offset(const char* name);
> 29: #endif // SHARE_CDS_CDSCONSTANTS_HPP

Instead of stand-alone functions, I think it's better to group them into a class:


class CDSConstants : AllStatic {
  static int    get_constant(const char* name);
  static size_t get_offset(const char* name);
};

-------------

PR: https://git.openjdk.java.net/jdk/pull/5450


More information about the hotspot-runtime-dev mailing list