RFR: 8271569: Rename cdsoffsets.cpp to cdsConstants.cpp

Yumin Qi minqi at openjdk.java.net
Thu Sep 9 18:24:31 UTC 2021


Changed cdsOffsets.cpp to cdsConstants.cpp, now the offsets and constants are initialized static and searched separately.
The offsets array could not use 'constexpr' since g++ on MacOs and VSC++ on Windows complained reinterpret_cast in 'offset_of' should not be used in constexpr initialization. Changed some field access for forming global list first.

Note with 'git mv' to rename cdsoffset.cpp to cdsConstants.cpp, same for cdsoffsets.hpp to cdsConstants.hpp, due to the contents changed more than 50% so git will not think cdsConstants.cpp is renamed from cdsoffsets.cpp. Instead, it is regarded as a new file.

Tests: ter1-4

Thanks
Yumin

-------------

Commit messages:
 - 8271569: Rename cdsoffsets.cpp to cdsConstants.cpp

Changes: https://git.openjdk.java.net/jdk/pull/5450/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5450&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8271569
  Stats: 336 lines in 10 files changed: 163 ins; 129 del; 44 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5450.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5450/head:pull/5450

PR: https://git.openjdk.java.net/jdk/pull/5450


More information about the hotspot-runtime-dev mailing list