RFR: 8271569: Clean up the use of CDS constants and field offsets [v3]
David Holmes
dholmes at openjdk.java.net
Tue Sep 14 00:53:09 UTC 2021
On Mon, 13 Sep 2021 23:12:19 GMT, Yumin Qi <minqi at openjdk.org> wrote:
>> Changed cdsOffsets.cpp to cdsConstants.cpp, now the offsets and constants are initialized static and searched separately.
>> The offsets array could not use 'constexpr' since g++ on MacOs and VSC++ on Windows complained reinterpret_cast in 'offset_of' should not be used in constexpr initialization. Changed some field access for forming global list first.
>>
>> Note with 'git mv' to rename cdsoffset.cpp to cdsConstants.cpp, same for cdsoffsets.hpp to cdsConstants.hpp, due to the contents changed more than 50% so git will not think cdsConstants.cpp is renamed from cdsoffsets.cpp. Instead, it is regarded as a new file.
>>
>> Tests: ter1-4
>>
>> Thanks
>> Yumin
>
> Yumin Qi has updated the pull request incrementally with one additional commit since the last revision:
>
> Rollled back _base_region_crc to private, changed CDSConst's value from type int to size_t
src/hotspot/share/cds/cdsConstants.hpp line 37:
> 35: public:
> 36: static CDSConst offsets[];
> 37: static CDSConst constants[];
Why are these public?
-------------
PR: https://git.openjdk.java.net/jdk/pull/5450
More information about the hotspot-runtime-dev
mailing list