RFR: 8294000: Filler array klass should be in jdk/vm/internal, not in java/vm/internal

Thomas Schatzl tschatzl at openjdk.org
Mon Sep 19 12:42:49 UTC 2022


On Mon, 19 Sep 2022 11:24:59 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:

> Hi all,
> 
>   can I have reviews for the move of the internal filler array klass from `java/vm/internal/` to `jdk/vm/internal` - I noticed that typo in some recent `jmap` dump. All internal klasses are in the `jdk.` package... idk how this slipped through the original change.
> 
> With this change it shows up as
> `   2:           428       13291728  jdk.internal.vm.FillerArray (java.base at 20-internal)`
> which I believe is best.
> 
> Testing: local compilation, checking `jmap` output for instances of this klass directly, the `gc/TestFillerObjectInstantiation.java` jtreg test
> 
> Thanks,
>   Thomas

The given name does not seem to have any particular requirements in `TypeArrayKlass::create_klass` apart from being unique. So I chose the name to look "best" in the `jmap` output; otherwise it would show that `L...;` there too.
Other classes from `jdk.vm.internal.*` also show up without the `L...;` in the `jmap` output.

The string passed to `TypeArrayKlass:create_klass` for basic types also does not have `L...;` either, it's e.g. `[I`. Only element types of arrays have the `L...;` in jmap histogram, e.g. `[Ljava.util.concurrent.ConcurrentHashMap$Node;`. But this (internal) klass doesn't expose its element type.

So I thought removing the `L...;` would be just fine.

Obviously I'll change the name to whatever is correct.

-------------

PR: https://git.openjdk.org/jdk/pull/10336


More information about the hotspot-runtime-dev mailing list