RFR: JDK-8312018: Improve reservation of class space and CDS [v8]

Thomas Stuefe stuefe at openjdk.org
Tue Aug 29 13:47:13 UTC 2023


On Tue, 29 Aug 2023 10:43:52 GMT, Andrew Dinn <adinn at openjdk.org> wrote:

>> src/hotspot/share/memory/metaspace.cpp line 597:
>> 
>>> 595:   // the encoding base to zero anyway: the encoding base has to be the base of the mapped archive
>>> 596:   // (ultimately, the start address of the region we are reserving here).
>>> 597:   const bool try_in_low_address_ranges = !cds_runtime;
>> 
>> I think `try_in_low_address_range` would be a far better name for the method param than either the current `cds_runtime` or your original `strict_base`, following the principle that *it does what it says on the tin*.
>
> Bike shedding done, you may stick with the current name if you wish.

I like `try_in_low_address_range`, I will use that. Note that we hopefully can remove this clutch in the future.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15041#discussion_r1308847336


More information about the hotspot-runtime-dev mailing list