RFR: JDK-8301990: Separate Arguments::parse into two phases
Kim Barrett
kbarrett at openjdk.org
Thu Feb 9 10:43:46 UTC 2023
On Tue, 7 Feb 2023 16:21:07 GMT, Justin King <jcking at openjdk.org> wrote:
> Separate out some logic from `Arguments::parse` into a separate preceding phase, preprocessing. See JDK-8301990 and JDK-8299196 for more details.
Changes requested by kbarrett (Reviewer).
src/hotspot/share/runtime/arguments.hpp line 278:
> 276: friend class Arguments;
> 277:
> 278: void* _impl = nullptr;
I suggest making PreprocessedArguments a private nested class, with only declaration here. Then make the type of `_impl` be `PreprocessedArguments*` and get rid of a bunch of `static_cast`s in the implementation. Also give `_impl` a better name.
-------------
PR: https://git.openjdk.org/jdk/pull/12458
More information about the hotspot-runtime-dev
mailing list