RFR: JDK-8301990: Separate Arguments::parse into two phases [v2]

Justin King jcking at openjdk.org
Mon Feb 13 17:49:00 UTC 2023


On Thu, 9 Feb 2023 10:39:58 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> Justin King has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Updates based on review
>>   
>>   Signed-off-by: Justin King <jcking at google.com>
>
> src/hotspot/share/runtime/arguments.hpp line 278:
> 
>> 276:     friend class Arguments;
>> 277: 
>> 278:     void* _impl = nullptr;
> 
> I suggest making PreprocessedArguments a private nested class, with only declaration here.  Then make the type of `_impl` be `PreprocessedArguments*` and get rid of a bunch of `static_cast`s in the implementation.  Also give `_impl` a better name.

Renamed `PreprocessedArguments` to `PreprocessedImpl`, predeclared in header, got rid of `void*`, and added a comment to `_impl`.

-------------

PR: https://git.openjdk.org/jdk/pull/12458


More information about the hotspot-runtime-dev mailing list