RFR: 8351046: Rename ObjectMonitor functions [v2]
Coleen Phillimore
coleenp at openjdk.org
Mon Mar 10 12:47:54 UTC 2025
On Mon, 10 Mar 2025 12:35:50 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
>> src/hotspot/share/runtime/objectMonitor.cpp line 1191:
>>
>>> 1189:
>>> 1190: if (node->is_wait() && !node->at_reenter()) {
>>> 1191: bool acquired_monitor = vthread_waitReenter(current, node, cont);
>>
>> Should this be vthread_wait_reenter?
>
> Thank you for seeing this. I've changed that one too. There are still a couple of data members with mixed names. _WaitSet, _WaitSetMonitor and _SpinDuration. Should I change them too?
Then this leaves TState in ObjectWaiter which we should deal with separately.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23450#discussion_r1987214612
More information about the hotspot-runtime-dev
mailing list