RFR: JDK-8261079: Fix support for @hidden in classes and interfaces [v3]

Hannes Wallnöfer hannesw at openjdk.java.net
Thu Feb 11 12:10:44 UTC 2021


On Thu, 11 Feb 2021 00:32:07 GMT, Jonathan Gibbons <jjg at openjdk.org> wrote:

>> Hannes Wallnöfer has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains four commits:
>> 
>>  - Merge master
>>  - JDK-8261079: Updates to review comments
>>     - Use separate unchecked/uncached code path when checking for @hidden tag on non-incuded elements
>>     - Rename OverridingMethodInfo to OverriddenMethodInfo to better reflect its purpose
>>  - JDK-8261079: Finish tests and small fixes
>>  - JDK-8261079: Fix support for @hidden in classes and interfaces
>
> Two primary areas:
> 
> 1. I think the changes to Utils to determine if a tag is hidden can be improved/simplified
> 2. I'm trying to understand the changes to `VisibleMemberTable`

Thanks for the review, Jon! 

I pushed a new commit that should address your concerns. For the lookup of `@hidden` tags in non-included elements I added a new `hasBlockTagUnchecked` method that avoids caching and doclint checking by using  `getDocCommentInfo` as you suggested. Note that this isn't used for the javafx "treatAsPrivate" tag as changing the semantics of an undocumented/internal tag didn't seem like a good idea on second thought.

Regarding the renaming of `overrider` to `overridden`: the old name was a misnomer, the new name actually reflects the meaning of the field as it contains the overridden method, not the overriding one. I actually went the whole way and renamed the nested class as well, from `OverridingMethodInfo` to `OverriddenMethodInfo`.

-------------

PR: https://git.openjdk.java.net/jdk/pull/2406


More information about the javadoc-dev mailing list