Code review request for SecurityManager changes
Mark Reinhold
mr at sun.com
Tue May 11 11:56:37 PDT 2010
> Date: Tue, 11 May 2010 14:46:04 -0400
> From: sean.mullan at oracle.com
> On 5/11/10 1:14 PM, Mark Reinhold wrote:
>> [50] Split long method invocations across multiple lines by splitting
>> the argument list rather than by separating the method name from the
>> argument list. This should read:
>>
>> Class<?> c = super.defineClass(name, b, off, len,
>> new CodeSource(null),
>> new (CodeSigner[])null);
>
> Actually the CodeSource constructor has 2 arguments above. So which is preferable:
>
> Class<?> c = super.defineClass(name, b, off, len,
> new CodeSource(null,
> (CodeSigner[])null);
>
> or:
>
> Class<?> c = super.defineClass(name, b, off, len,
> new CodeSource(null,
> (CodeSigner[])null);
The latter is much more readable.
- Mark
More information about the jigsaw-dev
mailing list