Service provider module resolution <was> Re: Services/configuration/context webrevs
mark.reinhold at oracle.com
mark.reinhold at oracle.com
Fri Aug 24 15:23:57 PDT 2012
2012/8/1 7:46 -0700, paul.sandoz at oracle.com:
> http://cr.openjdk.java.net/~psandoz/jigsaw/resolver-services/webrev.4/
Overall this looks very good, and the resulting behavior will definitely
be more intuitive.
Resolver.java
[84-94] Please follow the local convention of using "//" to introduce
comments on implementation internals. This makes it easy to
distinguish them from actual doc comments.
[88] s/synthesizedServiceDependencies/synthesizedServiceDependences/
Dependencies and dependences are different things. You're talking
about the latter here.
[432-444] //
[445-473] dependencies -> dependences
[455,460] s/: / : /
[514-556] This code is crying out to be placed in its own method, say
`resolveServices`.
As to the tests, I'm not comfortable with splitting what's logically a
single test, which happens to involve a bunch of small files, into a
bunch of actual small files. That just makes the test harder to read and
harder to maintain. I agree that the current shell hackery has issues,
particularly around portability, but we can address that in other ways.
Please use existing mechanisms and conventions for now, until we have
something better.
(One idea (just discussed with Jon and Mandy here in the hallway) is to
write a test library that understands a simple "snippet" file format.
When run it would extract each snippet into a separate source file,
possibly doing some template expansion along the way, and then perform
the requested actions on them. This is, however, for another day.)
- Mark
More information about the jigsaw-dev
mailing list