Request for Review: CR#8001667, second attempt

Henry Jen henry.jen at oracle.com
Wed Dec 5 22:57:23 PST 2012


Hi,

This update reflect changes based on feedbacks for last version, the
changes are

- rename reverse() to reverseOrder()
- rename Comparator.compose to Comparator.thenComparing
- add 4 Comparator.thenComparing methods take [Int|Long|Double]Function
to enable fluent syntax like this example,

people.sort(Comparators.comparing(People::getFirstName).thenComparing(People.getLastName))

vs previously,

   people.sort(Comparators.comparing(Person::getName))
   Comparator<Person> byLastFirst
       = Comparators.comparing(Person::getLastName)
                   .compose(Comparators.comparing(Person::getFirstName))

Please review and comment on the webrev[1] and specdiff[2].

[1] http://cr.openjdk.java.net/~henryjen/ccc/8001667.1/webrev
[2]
http://cr.openjdk.java.net/~henryjen/ccc/8001667.1/specdiff/overview-summary.html

Cheers,
Henry


More information about the lambda-dev mailing list