Arrays methods
Tim Peierls
tim at peierls.net
Fri Jan 11 14:23:28 PST 2013
On Fri, Jan 11, 2013 at 5:07 PM, Brian Goetz <brian.goetz at oracle.com> wrote:
> I think a better option is just adding a small number of methods to take
> an array and produce a stream of valid indexes:
>
> IntStream indexes(T[])
> IntStream indexes(int[])
> ...
>
> Because then the user can mix and match his own:
>
> // generate
> Arrays.indexes(array).forEach(**i -> { array[i] = f(i) });
>
That's appealingly simple, but I worry that it's too easy to write
something like this:
Arrays.indexes(a).forEach(i -> { b[i] = f(i) }); // oops, a is not b
And <bikeshed> isn't "indices" better than "indexes"? </bikeshed>
--tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130111/d571608f/attachment.html
More information about the lambda-libs-spec-experts
mailing list