> That's appealingly simple, but I worry that it's too easy to write > something like this: > > Arrays.indexes(a).forEach(i -> { b[i] = f(i) }); // oops, a is not b' Yep, that's the downside, as far as I can see. Lots of upside, though. > And <bikeshed> isn't "indices" better than "indexes"? </bikeshed> OK :)