Function type naming conventions

Joe Bowbeer joe.bowbeer at gmail.com
Thu Jan 24 11:03:55 PST 2013


On Thu, Jan 24, 2013 at 10:52 AM, Dan Smith <daniel.smith at oracle.com> wrote:

> Let me propose a slightly different convention: if the base type is
> parameterized in both its parameters and return, then the "To" prefix is
> mandatory.  If not, "To" is not used.
>
>
This works for me if the base name is descriptive enough.
 IntSupplier, IntConsumer, even IntBlock (now that I know what a Block is).



> —Dan
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130124/ab633f2b/attachment.html 


More information about the lambda-libs-spec-experts mailing list