tee()

Doug Lea dl at cs.oswego.edu
Thu Jan 24 17:11:54 PST 2013


On 01/24/13 20:00, Joe Bowbeer wrote:
> I'm OK with peek() even though it has other meanings on IO streams.
>
> Is the name leak() is more to your liking?

I can't think of a good name for the the little idiom of
   ....map(x -> { use(x); return x; })...

Which seems more like an IDE thing than an API thing anyway.

But then again, I don't like practically all of the
convenience methods, so discount my vote accordingly.

-Doug



>
> Joe
>
>
> On Thu, Jan 24, 2013 at 4:47 PM, Doug Lea <dl at cs.oswego.edu
> <mailto:dl at cs.oswego.edu>> wrote:
>
>     On 01/24/13 15:43, Kevin Bourrillion wrote:
>
>         If it really must stay, I think I do like "peek" or "observe" over
>         "tee". But I
>         would love to drop it.
>
>
>     In case it is not too late to vote to drop this, I vote to drop it.
>     And if too late, I vote to name it something other than any of these.
>
>     -Doug
>
>
>



More information about the lambda-libs-spec-experts mailing list