Function type naming conventions
Tim Peierls
tim at peierls.net
Tue Jan 29 09:30:12 PST 2013
That's a good start. (Typo in lambda signature after Supplier.)
Still some holes, e.g., doesn't tell me which of the following is right:
ObjObjToIntFunction
BiToIntFunction
ToIntBiFunction
--tim
On Tue, Jan 29, 2013 at 12:06 PM, Paul Sandoz <paul.sandoz at oracle.com>wrote:
>
> On Jan 29, 2013, at 5:48 PM, Kevin Bourrillion <kevinb at google.com> wrote:
>
> Does anyone have a complete and current taxonomy of where exactly we've
> ended up with all this (leaving out all the history of how we got here)?
>
>
> Does the following suffice?
>
>
> http://hg.openjdk.java.net/lambda/lambda/jdk/file/5d4167b7bf8c/src/share/classes/java/util/function/package-info.java
>
> Paul.
>
>
>
> On Thu, Jan 24, 2013 at 2:47 PM, Tim Peierls <tim at peierls.net> wrote:
>
> On Thu, Jan 24, 2013 at 5:20 PM, Joe Bowbeer <joe.bowbeer at gmail.com>wrote:
>
> +1 ObjIntBlock (or a more descriptive "Block" name if one is selected)
>
>
> Agreed.
>
> Works well in conjunction with Dan Smith's suggestion ('if the base type
> is parameterized in both its parameters and return, then the "To" prefix is
> mandatory. If not, "To" is not used.'), omitting To and Bi where they
> aren't needed.
>
> --tim
>
>
>
>
> --
> Kevin Bourrillion | Java Librarian | Google, Inc. | kevinb at google.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130129/3fae856a/attachment.html
More information about the lambda-libs-spec-experts
mailing list