ConcurrentHashMap/ConcurrentMap/Map.compute
Doug Lea
dl at cs.oswego.edu
Fri Dec 7 09:43:05 PST 2012
On 12/07/12 11:50, Brian Goetz wrote:
> Extraneous {@code fragment in compute().
Thanks!
>
> I think the semantics of compute can be explained better; people will likely
> confuse it with computeIfAbsent. There's an aspect of reduction going on
> here; the remapping function is like a reducer under the "null means nothing
> there" semantics. It would be great if the name could suggest this; barring
> that the docs should explain it. Only when users get to the "create or
> append" example will they get it.
Right: compute() and merge() are paired in this sense.
(and computeIfPresent and computeIfAbsent paired in a different sense).
So if we can think of a better name, please suggest one.
No one did when I asked on c-i list last year for CHM.
>
> Seems like you didn't yet fold in the bits about scope of atomicity? Will
> that go in CM docs?
>
> What do you mean by "possibly iterative equivalent of"?
I told you that they are a little hard to understand :-)
The "possibly iterative" is explained later by the sentence:
"In concurrent contexts, if attempts to replace or
remove fail, they may be retried after remapping updated values."
And the scope is "explained" by adding the
"or the application of the remapping function" in the
atomicity disclaimer parag.
One could /should go into a lot more detail about using
functions in concurrent/parallel contexts, but I think
that there will need to be some added package-level discussion
of this somewhere anyway, that this can refer to.
-Doug
More information about the lambda-libs-spec-observers
mailing list