December 2012 Archives by thread
Starting: Sat Dec 1 05:43:44 PST 2012
Ending: Mon Dec 31 13:11:36 PST 2012
Messages: 395
- Stream generators
Brian Goetz
- Stream.flatMap signature is not correct
Kevin Bourrillion
- Bikeshed opportunity: filter/map/reduce naming
Brian Goetz
- java.util.stream
Remi Forax
- Stream and Iterator
Remi Forax
- BaseStream & Stream
Remi Forax
- Bikeshed opportunity: filter/map/reduce naming
Raab, Donald
- Bikeshed opportunity: filter/map/reduce naming
Howard Lovatt
- Request for Review : CR#8004015 : [2nd pass] Add interface extends and defaults for basic functional interfaces
Mike Duigou
- Primitive streams and optional
Doug Lea
- ConcurrentHashMap/ConcurrentMap/Map.compute
Doug Lea
- Remove cumulate from Stream interface
Remi Forax
- skip, limit and slice
Remi Forax
- Stream.toArray()
Remi Forax
- Request for Review : CR#8004015 : [final (?) pass] Add interface extends and defaults for basic functional interfaces
David Holmes
- Request for Review : CR#8004015 : [final (?) pass] Add interface extends and defaults for basic functional interfaces
Mike Duigou
- Updated our training kata to use the 12/4 Lambda Binaries
Raab, Donald
- Combiner & BiFunction
Remi Forax
- Stream construction APIs
Brian Goetz
- Constructing parallel streams
Brian Goetz
- "Cancelable" streams
Brian Goetz
- groupBy / reduceBy
Brian Goetz
- Combiner -> BiFunction?
Brian Goetz
- Forms for reduce() -- part 1
Brian Goetz
- Forms for reduce() -- part 2
Brian Goetz
- RFR : CR8004015 : Add parent interfaces and default methods to basic functional interfaces
Mike Duigou
- The implementation of default methods
David Holmes
- Collection.addAll(stream) should not be named addAll
Remi Forax
- Stream, spliterator, supplier and size
Remi Forax
- IntIterator
Remi Forax
- Forms for reduce() -- part 1
Tim Peierls
- Streamable
Brian Goetz
- toArray
Brian Goetz
- apply
Doug Lea
- Binary Conversion functions
Doug Lea
- Fixing flatMap: bikeshed edition
Brian Goetz
- flatMap
Brian Goetz
- Spliterator
Doug Lea
- Getting rid of pull
Brian Goetz
- Fine Grained Coordinated Parallelism in a Real World Application
Raab, Donald
- Into
Brian Goetz
- cumulate
Brian Goetz
- unordered()
Brian Goetz
- Foo.Of{Int,Long,Double} naming convention
Brian Goetz
- Foo.Of{Int,Long,Double} naming convention
Tim Peierls
- Foo.Of{Int,Long,Double} naming convention
Doug Lea
- Foo.Of{Int,Long,Double} naming convention
Remi Forax
- Foo.Of{Int,Long,Double} naming convention
Joe Bowbeer
- Foo.Of{Int,Long,Double} naming convention
David Holmes
- Proposed rename of Map.forEach(BiBlock<? super K, ? super V> block)
Raab, Donald
- Into
Raab, Donald
- A couple of tabulate/Tabulators.groupBy examples
Raab, Donald
- Spliterator update
Brian Goetz
- Tabulators, reducers, etc
Brian Goetz
- Tabulators -- a catalog
Brian Goetz
- Cancelation -- use cases
Brian Goetz
- Primitive streams
Brian Goetz
- Request for review: proposal for @FunctionalInterface checking
Joe Darcy
- overload patterns/anti-patterns
Doug Lea
- Streams -- philosophy
Brian Goetz
- Looking forward to 2013
Gernot Neppert
- random streams
Brian Goetz
- Background: pipeline architecture
Brian Goetz
Last message date:
Mon Dec 31 13:11:36 PST 2012
Archived on: Mon Dec 31 13:11:51 PST 2012
This archive was generated by
Pipermail 0.09 (Mailman edition).