ConcurrentHashMap/ConcurrentMap/Map.compute
Brian Goetz
brian.goetz at oracle.com
Fri Dec 14 10:27:10 PST 2012
>>> But given computeIfAbsent, the name computeIfPresent seems forced,
>>> and then computeIfAbsentOrPresent==compute seems forced. And if you
>>> see the scheme laid out in this way, looks OK. Which is presumably
>>> why all the CHMV8 users seem to like it.
>>
>> What about recompute for compute, and recomputeIfPresent for
>> computeIfPresent?
>
> I forget what c-i list feedback led me to change the initial
> CHMV8 recompute() to computeIfPresent() but I can scan archives/replies
> if anyone cares.
Would be useful if you could dig up. Very often the problem is not an
issue with a specific name, but their relationships, which mean they
sometimes need to be considered as a group.
More information about the lambda-libs-spec-observers
mailing list