Fixing flatMap: bikeshed edition

Doug Lea dl at cs.oswego.edu
Mon Dec 17 07:17:21 PST 2012


On 12/17/12 10:13, Brian Goetz wrote:
> I'm working on a better API for flatMap.  But, part of fixing flatMap is the
> name.  If we were mapping elements to Streams, flatMap would be a fine name, but
> that's not what we're doing (nor is it all that practical.)  So the name is
> already a bit misleading.
>
> Candidates:
>   - mapMulti
>   - explode
>

merge?
mergedMap?

-Doug





More information about the lambda-libs-spec-observers mailing list