review request (L): 7032323: code changes for JSR 292 EG adjustments to API, through Public Review

John Rose john.r.rose at oracle.com
Thu May 26 13:33:23 PDT 2011


On May 26, 2011, at 1:21 PM, Charles Oliver Nutter wrote:

> isInvalid seems a bit double-negativy to me.

That's my hesitation.  Consider the use case:

  void maybeCleanUpMess(SwitchPoint sp) {
    if (!mysp.isInvalid())  return;
    ... // do cleanup after invalidation
  }

It reads better as:
    if (mysp.isValid())  return;

-- John


More information about the mlvm-dev mailing list