RFR 8144355: JDK 9 changes to ZipFileSystem to support multi-release jar files

Alan Bateman Alan.Bateman at oracle.com
Fri Dec 18 13:34:58 UTC 2015


On 15/12/2015 00:08, Steve Drach wrote:
> Hi,
>
> I’ve updated the webrevs to take into account Sherman’s comments.
>
> Issue: https://bugs.openjdk.java.net/browse/JDK-8144355
>
> Change to modules.xml: 
> http://cr.openjdk.java.net/~sdrach/8144355/top/webrev.01/index.html 
> <http://cr.openjdk.java.net/%7Esdrach/8144355/top/webrev.00/index.html>
>
> Changes to ZipFileSystem: 
> http://cr.openjdk.java.net/~sdrach/8144355/jdk/webrev.01/index.html 
> <http://cr.openjdk.java.net/%7Esdrach/8144355/jdk/webrev.01/index.html>
>
modules.xml looks fine.

The changes to ZipFileSystem* looks okay although I wonder if getEntry0 
should be renamed to getEntry as it's cleaner when overridden in 
JarFileSystem.

JarFileSystem looks okay and I assume the recursion in walk should never 
be an issue. A minor nit is that is that it would be good to keep the 
style consistent with the existing code if you can. Really long source 
lines are annoying when looking at side-by-side diffs. Also good if the 
main comment in JarFileSystem could be expanded a bit, also the comments 
in the methods can use /** instead of /*.

The tests looks good. You might want to check the copyright header on 
MultiReleaseJarTest, the others look okay.

-Alan.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/nio-dev/attachments/20151218/ef5f793f/attachment.html>


More information about the nio-dev mailing list