RFR: 8338383: Implement JEP 491: Synchronize Virtual Threads without Pinning [v9]
Coleen Phillimore
coleenp at openjdk.org
Fri Oct 25 22:39:21 UTC 2024
On Fri, 25 Oct 2024 21:29:05 GMT, Patricio Chilano Mateo <pchilanomate at openjdk.org> wrote:
>> I see that in lightweightSynchronizer.cpp we already use the name `locking_thread` (although `LightweightSynchronizer::inflate_into_object_header` still uses `inflating_thread`). So how about using `locking_thread` instead? I can fix `LightweightSynchronizer::inflate_into_object_header` too.
>
>> If it's always the current thread, then it should be called 'current' imo.
>>
> The inflating thread is always the current one but it's not always equal to `inflating_thread`.
I thought locking_thread there may not be the current thread for enter_for() in deopt. It's the thread that should hold the lock but not the current thread. But it might be different now.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21565#discussion_r1817423564
More information about the nio-dev
mailing list