RFR: 8338383: Implement JEP 491: Synchronize Virtual Threads without Pinning [v9]
David Holmes
dholmes at openjdk.org
Mon Oct 28 00:41:37 UTC 2024
On Fri, 25 Oct 2024 22:29:56 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
>>> If it's always the current thread, then it should be called 'current' imo.
>>>
>> The inflating thread is always the current one but it's not always equal to `inflating_thread`.
>
> I thought locking_thread there may not be the current thread for enter_for() in deopt. It's the thread that should hold the lock but not the current thread. But it might be different now.
The thread passed in need not be the current thread, and IIUC is the thread that should become the owner of the newly inflated monitor (either current thread or a suspended thread). The actual inflation is always done by the current thread.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21565#discussion_r1818240440
More information about the nio-dev
mailing list