RFR: 8092272: [D3D 3D] Need a robust 3D states management for texture [v2]

Ambarish Rapte arapte at openjdk.org
Fri Dec 1 10:10:19 UTC 2023


On Wed, 15 Nov 2023 11:39:30 GMT, Lukasz Kostyra <lkostyra at openjdk.org> wrote:

>> 1. Not when it will be promoted to public API. Adding record components breaks backwards compatibility, so making this a record will not allow adding more configuration later on. What might be possible is making it an interface and using a record as an implementation.
>> 2. I think that this class can go beyond sampler configurations. For example, wrapping is a render state, not a sampler state. Maybe something more general like "TextureParameters" can work.
>
> I agree with 2. and I also think that `TextureParameters` would be a better name for this.
> 
> This should also follow in below method names and such (ex. `setTextureParameters()` instead of `setTextureData()`)

These properties/parameters are actually Sampler properties. But `Sampler` is implementation detail and so is `Texture`. Will it be good idea or overkill to use different naming instead, like for example how we use [ImageSmoothing](https://openjfx.io/javadoc/21/javafx.graphics/javafx/scene/canvas/GraphicsContext.html#setImageSmoothing(boolean))

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/1281#discussion_r1411882540


More information about the openjfx-dev mailing list