RFR: 8324658: Allow animation play/start/stop/pause methods to be called on any thread [v5]
Kevin Rushforth
kcr at openjdk.org
Mon Jan 29 13:21:50 UTC 2024
On Mon, 29 Jan 2024 09:20:27 GMT, Jose Pereda <jpereda at openjdk.org> wrote:
>>> However, I'm not sure about the method naming `OnFxThread`, as it might imply that what it does is already done on the FX thread, therefore not needing to be wrapped up by `runOnFxThread`.
>>
>> I understand what you mean, but the way I see it is that they do already run on the FX thread because that's the only reason they exist. I could use something like `runMustBeOnFxThread` or `runOnlyFromFxThread` if that's better.
>> Note that there are already `do___` methods (bad names IMO), and adding `run___` might be confusing.
>
> Probably you won't like `xxImpl` either?
> I'm not sure we should start adding `runMustBeOnFxThread` to every method name out there that should run on the FX thread. In this case, maybe we could simply add a small javadoc with a comment, and that's it. Neither will enforce a real check about that.
I was also going to suggest `xxImpl` with a short javadoc comment. That is a pattern we use elsewhere. I don't dislike the current name, but I can see Jose's point.
-------------
PR Review Comment: https://git.openjdk.org/jfx/pull/1352#discussion_r1469540887
More information about the openjfx-dev
mailing list