[foreign-abi] RFR: 8248560: Specify the behaviour of the ForeignLinker returned by CSupport::getSystemLinker
Jorn Vernee
jvernee at openjdk.java.net
Tue Sep 15 16:28:47 UTC 2020
On Tue, 15 Sep 2020 15:01:56 GMT, Maurizio Cimadamore <mcimadamore at openjdk.org> wrote:
>> Hi,
>>
>> This patch creates a new class called CLinker, which extends ForeignLinker. The new class documents how linking works
>> in the class's javadoc. This is done in a separate class since the specification is only relevant to linkers that
>> support the C ABI. With the new class there was no more need to have CSupport, so the contents of CSupport has all
>> been move to CLinker.
>> After some offline discussion with Maurizio, we realized that it doesn't make much sense to expose platform specific
>> layout constants, since it is not possible to combine them with a platform specific linker any way, so for a particular
>> platform, there is only one set of layouts that can be used, namely the ones that are dynamically picked based on the
>> current platform. For that reason, all platform specific layouts have instead been moved to an internal PlatformLayouts
>> class. In order for downstream APIs (like jextract) to be able to filter out the ABI attributes from layouts, I've
>> added a String constant to CLinker that is used as a name prefix for all the ABI attribute names, so clients can for
>> instance filter attribute names using `.startsWith(ABI_ATTR_NAME)`. The ForeignLinker::name method has been dropped in
>> favor of an internal enum. The rest of the patch is just mechanical CSupport -> CLinker renames. Thanks, Jorn
>
> src/jdk.incubator.foreign/share/classes/jdk/incubator/foreign/CLinker.java line 99:
>
>> 97: * {@code permit}, {@code warn} or {@code debug} (the default value is set to {@code deny}).
>> 98: */
>> 99: static CLinker getSystemLinker() {
>
> Should be `getSystemLinker` here? Also, the string passed to the restricted check doesn't match the name of the method
Not sure what you mean here? The method is named getSystemLinker?
I've changed the message text.
-------------
PR: https://git.openjdk.java.net/panama-foreign/pull/327
More information about the panama-dev
mailing list