[vectorIntrinsics+mask] RFR: 8266621: Add masking support for unary/ternary vector intrinsics [v2]

Xiaohong Gong xgong at openjdk.java.net
Thu May 20 09:08:45 UTC 2021


> Similar with [1], this patch adds the masking support for `unary/ternary` vector intrinsics. It adds the mask information to the original intrinsic methods which are called both by masked and non-masked unary/ternary operations. For non-masked operations, the mask class and value are set to null.
> 
> Also change to use the `"binaryMaskedOp"` for vector mask logical operations instead of` "binaryOp"`. So that all the original nary intrinsics and hotspot implementation can be removed.
> 
> Note that this patch only contains the Vector API java implementation and the hotspot intrinsics changes. No compiler mid-end and backend implementations are included.
> 
> [1] https://bugs.openjdk.java.net/browse/JDK-8264563

Xiaohong Gong has updated the pull request incrementally with one additional commit since the last revision:

  Rename back to unaryOp/binaryOp/ternaryOp

-------------

Changes:
  - all: https://git.openjdk.java.net/panama-vector/pull/80/files
  - new: https://git.openjdk.java.net/panama-vector/pull/80/files/242a5e89..1b9f5873

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=panama-vector&pr=80&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=panama-vector&pr=80&range=00-01

  Stats: 474 lines in 45 files changed: 3 ins; 0 del; 471 mod
  Patch: https://git.openjdk.java.net/panama-vector/pull/80.diff
  Fetch: git fetch https://git.openjdk.java.net/panama-vector pull/80/head:pull/80

PR: https://git.openjdk.java.net/panama-vector/pull/80


More information about the panama-dev mailing list