[vectorIntrinsics+mask] RFR: 8266621: Add masking support for unary/ternary vector intrinsics [v2]

Vladimir Ivanov vlivanov at openjdk.java.net
Thu May 20 10:22:37 UTC 2021


On Thu, 20 May 2021 09:08:45 GMT, Xiaohong Gong <xgong at openjdk.org> wrote:

>> Similar with [1], this patch adds the masking support for `unary/ternary` vector intrinsics. It adds the mask information to the original intrinsic methods which are called both by masked and non-masked unary/ternary operations. For non-masked operations, the mask class and value are set to null.
>> 
>> Also change to use the `"binaryMaskedOp"` for vector mask logical operations instead of` "binaryOp"`. So that all the original nary intrinsics and hotspot implementation can be removed.
>> 
>> Note that this patch only contains the Vector API java implementation and the hotspot intrinsics changes. No compiler mid-end and backend implementations are included.
>> 
>> [1] https://bugs.openjdk.java.net/browse/JDK-8264563
>
> Xiaohong Gong has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Rename back to unaryOp/binaryOp/ternaryOp

Looks good.

-------------

Marked as reviewed by vlivanov (Committer).

PR: https://git.openjdk.java.net/panama-vector/pull/80


More information about the panama-dev mailing list