[foreign-memaccess+abi] RFR: 8277657: OptimizedEntryBlob should extend RuntimeBlob directly
Jorn Vernee
jvernee at openjdk.java.net
Thu Nov 25 18:01:24 UTC 2021
On Thu, 25 Nov 2021 17:43:36 GMT, Maurizio Cimadamore <mcimadamore at openjdk.org> wrote:
>> This small refactoring makes OptimizedEntryBlob extend RuntimeBlob instead of BufferBlob.
>>
>> The motivation for doing this is that we don't want to inherit behavior from BufferBlob by accident which is not appropriate for OptimizedEntryBlob, which has happened in the past.
>>
>> This patch also reverts an earlier fix by Nick which made BufferBlob sub classes pass their header size through the BufferBlob constructor to RuntimeBlob's constructor, since this is no longer needed with this patch.
>
> src/hotspot/share/code/codeBlob.cpp line 297:
>
>> 295:
>> 296: AdapterBlob::AdapterBlob(int size, CodeBuffer* cb) :
>> 297: BufferBlob("I2C/C2I adapters", size, cb) {
>
> the header size here used to be sizeof(AdapterBlob), but now is sizeof(BufferBlob) - is that an issue?
This is not an issue since they are the same. Arguably the header size should be passed as `sizeof(AdapterBlob)` for clarity, but I've reverted this to how it is done in the mainline jdk to avoid unnecessary churn for the next JEP: https://github.com/openjdk/jdk/blob/master/src/hotspot/share/code/codeBlob.cpp#L292-L295
I think if it's worth fixing, it should be fixed in the mainline.
-------------
PR: https://git.openjdk.java.net/panama-foreign/pull/617
More information about the panama-dev
mailing list