Code review request, 7106773: 512 bits RSA key cannot work withSHA384 and SHA512

Sean Mullan sean.mullan at
Wed Jan 11 08:24:39 PST 2012

I think you might be trying too hard to find a word that fits the  "-able"
naming convention for one-method interfaces (Iterable, Callable, etc), but
perhaps that is unreasonable in this case.

You could simply call it Length:

public interface Length {

  int length();



On 1/11/12 7:14 AM, Weijun Wang wrote:
> This is better, at least more precise.
> On 01/11/2012 08:12 PM, Xuelei Fan wrote:
>> On 1/11/2012 8:09 PM, Weijun Wang wrote:
>>>>> BTW, I will change the interface name from "Lengthable" to "Measurable".
>>> Well, this is not much better. There are many things that can be
>>> measured, length, weight, duration. But at least it's a real word.
>> I still hesitate to use "Measurable". How about "LengthMeasurable"?
>> Xuelei

More information about the security-dev mailing list