RFR [9] 8144480: Remove test dependencies on sun.misc.BASE64Encoder and BASE64Decoder

Chris Hegarty chris.hegarty at oracle.com
Wed Dec 2 14:15:10 UTC 2015


On 02/12/15 14:03, Alan Bateman wrote:
>
> On 02/12/2015 12:08, Chris Hegarty wrote:
>> The regression tests in the jdk should be updated, where possible, to
>> use java.util.Base64.
>>
>> http://cr.openjdk.java.net/~chegar/Base64-test-updates/webrev/
> Should S11N be updated to serialize with JDK 8 so that the core
> reflection code isn't needed?

This is certainly possible and would make the test simpler, but
I followed the comments in the test ( it needs to be runnable on
older JDKs ).  I think this is a reasonable requirement since the
test contains bytes array that were generated on older JDKs. Of
course, the test could contain the older JDK code commented out.
If someone really wants to run it with 1.6, then they just make
the simple edits.

I'm ok with any of these solutions, or just removing the possibility
of running on older JDKs.

-Chris.


More information about the security-dev mailing list