RFR 9 test-only RFR 8177328 : java/lang/ClassLoader/securityManager/ClassLoaderTest.java times out with -Xcomp
Brent Christian
brent.christian at oracle.com
Tue May 9 23:23:49 UTC 2017
Brent Christian wrote:
> Mandy Chung wrote:
>>
>> I think we could take out the automatic module case as named module
>> would verify it. One refactor you can consider by separating them
>> in several @run actions.
>> ...
>> I think it would make the test easier to read and understand the cases
>> it cover.
>
> True. I'll see what I can do, then.
I've removed the test case for automatic modules, and added a @run
action for each policy file + system classloader configuration. I also
removed the code to compile test sources, using @build instead.
I also made some (hopefully) clarifying changes to the code.
The String[] argument to execute() is now separated into
args/status/message, instead of being lumped into one String[], and then
having to be split() out of a single String. Where execute() is called,
it's easier to read the args in order (versus assembled using
String.format()).
I also simplified the code for expected status/output, and made some
path variable names more descriptive.
Webrev:
http://cr.openjdk.java.net/~bchristi/8177328/webrev.01/
Thanks,
-Brent
More information about the security-dev
mailing list