RFR (S) 8215521: add microbenchmark to measure AccessController.getContext
Eric Caspole
eric.caspole at oracle.com
Fri Oct 4 14:25:25 UTC 2019
Hi Alan,
Here it is:
http://cr.openjdk.java.net/~ecaspole/JDK-8215521/02/webrev/
thanks,
Eric
On 10/4/19 02:21, Alan Bateman wrote:
>
>
> On 03/10/2019 22:27, eric.caspole at oracle.com wrote:
>> :
>>
>> http://cr.openjdk.java.net/~ecaspole/JDK-8215521/01/webrev/
>>
> The cast is bit ugly. In other cases, we create PrivilegedAction like
> the following to make it easier to read:
>
> PrivilegedAction<AccessControlContext> pa = () ->
> AccessController.getContext();
> return AccessController.doPrivileged(pa);
>
> -Alan
More information about the security-dev
mailing list