RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]
Patrick Concannon
pconcannon at openjdk.java.net
Wed Dec 2 16:34:19 UTC 2020
On Wed, 2 Dec 2020 09:42:09 GMT, Kartik Ohri <github.com+27751938+amCap1712 at openjdk.org> wrote:
>> Hi!
>> Kindly review this patch to replace switch statements with switch expressions (where it makes sense) in the http client modules. The rationale is to improve readability of the code.
>> Regards,
>> Kartik
>
> Kartik Ohri has refreshed the contents of this pull request, and previous commits have been removed. The incremental views will show differences compared to the previous content of the PR.
src/java.net.http/share/classes/jdk/internal/net/http/Http1HeaderParser.java line 119:
> 117: while (canContinueParsing(input)) {
> 118: switch (state) {
> 119: case INITIAL -> state = State.STATUS_LINE;
Looks good. Although, I think you can improve it further if you align the lambda operators as well
-------------
PR: https://git.openjdk.java.net/jdk/pull/1364
More information about the security-dev
mailing list