ECDSA Algorithms not available with jlink

Sean Mullan sean.mullan at
Mon May 11 11:42:44 UTC 2020


Thanks for letting us know about this. We would like to figure out what 
might be causing this. However, this is not the best forum for debugging 

Can you please file a bug at ?

Can you also attach the debug output when running with "java ..." to the bug report.

A test program that reproduces the issue would also be useful, but 
probably not necessary unless we cannot reproduce the issue.


On 5/11/20 4:50 AM, Michele Adduci wrote:
> Hello,
> my name is Michele Adduci and I've freshly subscribed to this mailing 
> list because I'm seeking for advice/help on an issue that arose during 
> the creation of a new application and I couldn't find my answers by 
> searching online.
> I'm using JDK 14.0.1 GA and trying to create a small redistributable 
> version of my application using the combo jlink + jpackage.
> In my application, I'm trying to validate some signatures with 
> algorithm such a||||||s SHA256withECDSA, SHA384withECDSA and 
> SHA512withECDSA. If I run my application with the standard JDK 
> distribution, the application is working correctly, but if I run it 
> with the result of jlink+jpackage, I get errors like
> "SHA256withECSA Signature not available"
> I've double-checked that is in place under the 
> 'runtime/lib' folder, but I've seen that the SunEC provider isn't 
> loaded at all during the start (just SUN and SunRSA are being loaded).
> The jlink modules I'm using are:
> java.desktop,java.smartcardio,,java.sql,java.logging,,java.xml.crypto,
> and my jlink command is the following one:
> jlink --strip-debug \
>       --strip-native-commands \
>       --bind-services \
>       --no-header-files \
>       --no-man-pages \
>       --compress=2 \
>       --module-path ${JAVA_HOME}/jmods \
>       --add-modules 
> java.desktop,java.smartcardio,,java.sql,java.logging,,java.xml.crypto, 
> \
>       --output jlink-runtime
> What am I doing wrong? The issue is present in both Windows and Linux 
> - I cannot test on Mac.
> Kind regards and thanks in advance for your help
> Michele Adduci
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the security-dev mailing list