RFR: 8267125: AES Galois CounterMode (GCM) interleaved implementation using AVX512 + VAES instructions [v4]
Anthony Scarpino
ascarpino at openjdk.java.net
Thu Jul 22 17:22:25 UTC 2021
On Fri, 16 Jul 2021 00:31:43 GMT, Valerie Peng <valeriep at openjdk.org> wrote:
>> Smita Kamath has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Updated AES-GCM intrinsic to match latest Java Code
>
> src/java.base/share/classes/com/sun/crypto/provider/GaloisCounterMode.java line 650:
>
>> 648: int originalOutOfs = 0;
>> 649: byte[] in;
>> 650: byte[] out;
>
> The name "in", "out" are almost used in all calls, it's hard to tell when these two are actually used. Can we rename them to make them more unique?
ok
-------------
PR: https://git.openjdk.java.net/jdk/pull/4019
More information about the security-dev
mailing list