RFR: 8264774: Implementation of Foreign Function and Memory API (Incubator) [v26]
Maurizio Cimadamore
mcimadamore at openjdk.java.net
Thu May 27 10:37:38 UTC 2021
> This PR contains the API and implementation changes for JEP-412 [1]. A more detailed description of such changes, to avoid repetitions during the review process, is included as a separate comment.
>
> [1] - https://openjdk.java.net/jeps/412
Maurizio Cimadamore has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 37 commits:
- Merge branch 'master' into JEP-412
- * Add missing `final` in some static fields
* Downgrade native methods in ProgrammableUpcallHandler to package-private
- Add sealed modifiers in morally sealed API interfaces
- Merge branch 'master' into JEP-412
- Fix VaList test
Remove unused code in Utils
- Merge pull request #11 from JornVernee/JEP-412-MXCSR
Add MXCSR save and restore to upcall stubs for non-windows platforms
- Add MXCSR save and restore to upcall stubs for non-windows platforms
- Merge branch 'master' into JEP-412
- Fix issue with bounded arena allocator
- Rename is_entry_blob to is_optimized_entry_blob
Rename as_entry_blob to as_optimized_entry_blob
Fix misc typos and indentation issues
- ... and 27 more: https://git.openjdk.java.net/jdk/compare/7278f56b...8bbddfc2
-------------
Changes: https://git.openjdk.java.net/jdk/pull/3699/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=3699&range=25
Stats: 14501 lines in 219 files changed: 8847 ins; 3642 del; 2012 mod
Patch: https://git.openjdk.java.net/jdk/pull/3699.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/3699/head:pull/3699
PR: https://git.openjdk.java.net/jdk/pull/3699
More information about the security-dev
mailing list