RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss
Sean Mullan
mullan at openjdk.java.net
Fri Mar 4 15:43:12 UTC 2022
On Thu, 3 Mar 2022 19:33:21 GMT, Andrey Turbanov <aturbanov at openjdk.org> wrote:
> Pass cause exception as constructor parameter is shorter and easier to read.
src/java.security.jgss/share/classes/sun/security/krb5/internal/crypto/dk/ArcFourCrypto.java line 161:
> 159: Ksign = getHmac(baseKey, new_ss);
> 160: } catch (Exception e) {
> 161: throw new GeneralSecurityException("Calculate Checkum Failed!", e);
Can you also fix the typo, "Checkum" should be "Checksum". Same comment applies to line 172.
-------------
PR: https://git.openjdk.java.net/jdk/pull/7682
More information about the security-dev
mailing list