RFR: 8296024: Usage of DIrectBuffer::address should be guarded [v3]
Per Minborg
pminborg at openjdk.org
Mon Nov 21 12:54:17 UTC 2022
On Mon, 21 Nov 2022 12:19:21 GMT, Alan Bateman <alanb at openjdk.org> wrote:
>> maybe just `bufferLock` and and just `acquireBuffer` ?
>
> Would it be possible to re-examine acquireSession returning Runnable and
> acquireSessionAsAutoCloseable returning AutoCloseable. The naming is bit awkward at most of the use sites and maybe we can do better.
I think it would be confusing to have overloads with the same name.
The `aquireSession(Buffer, boolean)` method is only used once and is used in `IOUtil` so we could rename it to `aquireSessionOrNull` and then rename `acquireSessionAsAutoCloseable` to `acquireSession`.
-------------
PR: https://git.openjdk.org/jdk/pull/11260
More information about the security-dev
mailing list