RFR: 8290368: Introduce LDAP and RMI protocol-specific object factory filters to JNDI implementation [v3]

Aleksei Efimov aefimov at openjdk.org
Thu Oct 13 17:45:26 UTC 2022


On Thu, 13 Oct 2022 12:29:54 GMT, Jaikiran Pai <jpai at openjdk.org> wrote:

>> Aleksei Efimov has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Change checkInput to be the global filter centric
>
> src/java.naming/share/classes/com/sun/naming/internal/ObjectFactoriesFilter.java line 59:
> 
>> 57:      * @return true - if the factory is allowed to be instantiated; false - otherwise
>> 58:      */
>> 59:     public static boolean checkGlobalFilter(Class<?> serialClass) {
> 
> I think the `serialClass` param should be renamed to `factoryClass` or something like that, since I think the `serialClass` reference comes from serialization/deserialization usage.

The name comes from `ObjectInputFilter.FilterInfo` - it's been renamed from `factoryClass`to make it clear that the supplied lambda fills-in the non-default `ObjectInputFilter.FilterInfo.serialClass()` method.

-------------

PR: https://git.openjdk.org/jdk/pull/10578



More information about the security-dev mailing list