RFR: 8306033: Resolve multiple definition of 'throwIOException' and friends when statically linking with JDK native libraries
Mark Powers
mark.powers at oracle.com
Mon Apr 24 22:01:38 UTC 2023
I'll take a look.
________________________________
From: security-dev <security-dev-retn at openjdk.org> on behalf of Jiangli Zhou <jiangli at openjdk.org>
Sent: Monday, April 24, 2023 10:27 AM
To: jmx-dev at openjdk.org <jmx-dev at openjdk.org>; security-dev at openjdk.org <security-dev at openjdk.org>; serviceability-dev at openjdk.org <serviceability-dev at openjdk.org>
Subject: Re: RFR: 8306033: Resolve multiple definition of 'throwIOException' and friends when statically linking with JDK native libraries
On Mon, 17 Apr 2023 16:56:31 GMT, Jiangli Zhou <jiangli at openjdk.org> wrote:
> - Make functions 'static' when feasible:
> - throwByName() in src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
> - throwByName(), throwIOException() and throwNullPointerException() in src/java.smartcardio/unix/native/libj2pcsc/pcsc_md.c.
> - throwByName() in src/jdk.crypto.cryptoki/share/native/libj2pkcs11/p11_util.c.
> - throwOutOfMemoryError() in src/java.smartcardio/share/native/libj2pcsc/pcsc.c.
> - Move throwDisconnectedRuntimeException() to src/jdk.crypto.cryptoki/share/native/libj2pkcs11/p11_util.c since it's only used in the file. Make it static.
> - Move throw_internal_error() to src/jdk.management/unix/native/libmanagement_ext/OperatingSystemImpl.c as it's only used in the file. Make it static.
>
> - Rename functions by following the existing naming usages in different libraries code:
> - Rename throwOutOfMemoryError() to gssThrowOutOfMemoryError() in libj2gss.
> - Rename throwOutOfMemoryError() to p11ThrowOutOfMemoryError() in libj2pks11.
> - Rename throwNullPointerException() to p11ThrowNullPointerException() in libj2pks11.
> - Rename throwIOException() to p11ThrowIOException() in libj2pks11.
> - Rename throwPKCS11RuntimeException() to p11ThrowPKCS11RuntimeException() in libj2pks11. This function only exists in libj2pks11. The rename is done so the function naming is consistent with the other throw<exception> functions.
>
> - Remove throw_internal_error() from src/java.management/share/native/libmanagement/management.h and src/java.management/share/native/libmanagement/management.c. It's not used.
> - Remove throw_internal_error() from src/jdk.management/share/native/libmanagement_ext/management_ext.h and src/jdk.management/share/native/libmanagement_ext/management_ext.c.
Gentle ping, please help review this PR. Thanks.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/13497#issuecomment-1520559203
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/security-dev/attachments/20230424/74e3816c/attachment.htm>
More information about the security-dev
mailing list